iRemember™ Release Notes
version 2.2.2 — 2008-March-31

System Requirements

The following are the minimum requirements for iRemember:
* A Macintosh computer with a PowerPC G4 or G5 processor, or an Intel processor.
+  Mac OS X version 10.3.9 or later.
+  Atleast 3GB of free hard disk space for installation.
+ 512 MB of random-access memory (RAM) installed.
+  Thousands of colors at 1024 x 768 monitor resolution.
+  DVD-ROM drive required for installation.
» iLife '05 or later recommended.
»  High quality inkjet printer. Printing of 12x12 scrapbooks requires a wide format printer.
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Documentation

iRemember's documentation comes in two forms:

First is a set of tutorials intended for users new to iRemember. (They should be especially helpful for users new to the
Macintosh.) We strongly recommend all users review our tutorials. They are easily printed, and require only 10-15 minutes each.
The concepts presented far outweigh your time investment and will be utilized in every scrapbook page you create!

To access the tutorials:
1.  Open the iRemember application. (Its default location is in the iRemember folder in the Applications folder.)
2. Select one of the tutorials from iRemember’s “Help” menu. The tutorials begin with “101 Getting Started”.

Second is a built-in, comprehensive, searchable help system designed for experienced users. It provides a complete reference
guide to the program's features and functions. This documentation is provided electronically to allow it to be easily updated,
inexpensive, and environmentally responsible. To access the comprehensive Help system, select “iRemember Help” from
iRemember’s “Help” menu.

Bug Fixes from 2.2.1 {0 2.2.2 (2008-March-31)
Bug Fixes
- Corrected a bug where, although Arrange > Content > Scale to Shape was paying attention to whether the content was a
photo or not, it had transposed the scaling values and, therefore, both content types were being scaled incorrectly.
» Corrected a bug where, on some Mac models, saving, printing or other operations could cause iRemember to quit
unexpectedly.
- Corrected a bug where, under some rare circumstances, saving a scrapbook could lose the content of a page and therefore
the next time the scrapbook was opened the page would be displayed as blank.
+ Improved recognition and recovery from any template that contains a corrupt image file. (Some files would be read, but then
not be printable.)
» Corrected a bug where, under some circumstances, changing the position of the thumbnail size slider in iRemember ClipArt
was not being reflected in the view of all clip art.

Enhancements and Bug Fixes from 2.2 {0 2.2.1 (2008-January-29)
Enhancements
» We have again improved iRemember ClipArt's loading speed.

Bug Fixes
+ Corrected a bug (introduced in 2.2) that prevented iRemember ClipArt from displaying the clip art on Panther (Mac OS 10.3.9).
» Corrected a bug (introduced in 2.2) where the rubber band selection rectangle colors were essentially unusable on Panther.
+ Corrected a bug (introduced in 2.2) where we were unintentionally logging out huge amounts of information (to the Console).
- Corrected a bug (introduced in 2.2) where Paste & Duplicate commands were causing shapes to become confused over
which image they were suppose to be displaying.

New Features, Enhancements and Bug Fixes from 2.1.2 to 2.2 (2008-January-11)

New Features
* In order to facilitate users sharing templates, we've added a Drop Zone checkbox to the Image tab of the Inspector. When



checked, a "Drop Photo Here" image is displayed in the Shape (when the Shape has no other image), and you are allowed
to pre-adjust the opacity and rotation for the final image.

» Option-clicking (holding down the Option key while clicking) with the Arrow tool, or using the Grabber Hand tool, selects the
frontmost unlocked shape under the mouse — essential when a Drop Zone is covered by another, locked shape.

» Graphics now display a "bounds wireframe" when they are selected.

+ iRemember ClipArt can now accept uncompressed "clip art packages" when dropped on iRemember ClipArt's main window.

Enhancements

- Default image scaling, based upon file type information, is more intelligent. When JPEG (photo type) files are dropped into a
shape, they are scaled to fill the entire shape with some cropping possible. Other file types continue to be scaled without any
cropping.

+ Selection handles are bigger, and hopefully easier to see.

» Locked graphics now have eight (distinct) handles instead of the single "lock icon" in the bottom right corner.

+ Selection handles now appear on top of all graphics and can therefore be manipulated more easily, even when, for example,
a background graphic is completely covered by a foreground graphic.

* The rubber band selection rectangle is now colored to make it easier to see.

+ Line graphics have gone back to being selected when any part of the line is intersected by the rubber band selection
rectangle. (This was unwittingly broken in version 1.5.)

» You must now click within a shape (or drag select with the rubber band) to select a shape. Clicking outside the shape (even if
within the shape's rectangular bounds) now always deselects the shape.

* You can now drop a photo into an unlocked shape that is behind one or more other locked shapes. (Some styles of templates,
for example those using a Border to "frame" a picture, make this necessary.)

- Text Areas, when drawn to the screen, now display "Double-click here to edit text" when they are empty (i.e., when they have
no text) and unlocked.

» Clicking in the gray area around the page now ends editing text.

* When you click outside a TextArea (to end editing text), editing stops but the TextArea now remains selected (unless you've
clicked another shape) so you can immediately use a Format menu command on all of the text within the area.

+ Arrange > Fit to > Page now rotates the shape back to a zero angle (compensating its image angle, if necessary) before
making the shape fit the page. Also, this command now takes the graphic's stroke width into account.

+ Both Arrange > Duplicate, and Arrange > Save As Template commands are less expensive (in terms of the final, resulting file
size).

+ Arrange > Save As Template now ensures "maximum usability" for the output template. In other words, all Drop Zones and
empty TextAreas will be unlocked, non-empty TextAreas will remain locked or unlocked (as you specified), and all other
graphics will be locked.

- Certain operations (e.g., changing pages) now display a progress bar if they are going to take a while.

+ The last used image print resolution is now saved with scrapbooks.

+ iRemember ClipArt is now smarter about declining drops that won't go nicely into the database.

Bug Fixes

+ Corrected a (Leopard only) bug where embedded images could be drawn in the wrong place when the window was zoomed
to a value other than 100%.

+ Corrected a (Leopard only) bug where the shadow of text was being drawn with an incorrect opacity (but only when the
TextArea was selected).

* Previously, if you had more than one document open, simply changing pages in one document could cause the current page
of another open document to "disappear". This has been corrected.

+ Corrected a bug where Reverting a document to its last saved version would cause the current page to display empty (until
you changed pages).

» While using the Arrow tool, holding down the Option key when the mouse is over any handle of a shape containing an image
no longer causes the mouse to change to the Grabber Hand tool. In other words, the Option key only converts the Arrow tool
to the Grabber Hand tool when the mouse is over a shape's embedded image, not when it is over one of the handles of such
a (selected) shape.

» The number of columns viewed in iRemember ClipArt is now adjusted, as necessary, when a user changes from the Store tab
back to the Library tab.

+ Corrected a bug where iRemember ClipArt's Store tab, running under later versions of Tiger, had become unable to download
clip art packages.

+ Users who install the full version after using the Trial will now view the full version's clip art database instead of the Trial's.

Bug Fix from 2.1.1 to 2.1.2 (2007-November-09)
- Corrected a bug (introduced in 2.1.1) in iRemember ClipArt where some searches could cause the application to become
unresponsive.

Enhancements and Bug Fixes from 2.1 to 2.1.1 (2007-October-31)

Enhancements
« This release is compatible with Leopard (Mac OS X 10.5).
+ iRemember ClipArt now loads significantly faster (up to 16 times faster in some cases), especially on older, slower machines.
+ Saving scrapbook documents now presents a progress bar.

Bug Fixes
+ Corrected a bug where creating a graphic caused iRemember to crash in Leopard, and another where iRemember ClipArt



was virtually unusable in Leopard.

+ Corrected a problem where some embedded images could display "pixelated" (that is, at a sub-optimal resolution).

- Corrected a bug where, under rather obscure circumstances, saving a document could leave one or more pages blank.

+ We now recognize (notifying the user) and recover (as best we can) from any template that contains a corrupt image file.

» Corrected a bug where undoing replacement of an embedded image that had a bitmap representation was not resizing the
image correctly during the undo.

- Corrected a few other obscure bugs.

New Features, Enhancements and Bug Fixes from 2.0.2 to 2.1 (2007-July-13)

New Features

+ Added iPhoto book sizes to the “Layout Size” popup menu in the Scrapbook Setup sheet (and a section in Help's Frequently
Asked Questions explaining how to get scrapbooks printed & bound via iPhoto's book service).

+ Added two new PDF tutorials (in the Help menu) to help new users become productive faster.

+ Added display of a "boundary line" when selected Text and Shapes do not have a stroke.

» Added the Deselect All command to the Edit menu. You can also deselect all shapes by hitting the Esc key or clicking in the
gray area around the page.

+ Added “Center Horizontally on Page” and “Center Vertically on Page” commands to the Arrange menu.

+ Added “Fit to > Content” command to the Arrange menu.

+ Added “Content” submenu to the Arrange menu containing, “Scale to Shape”, “Center”, “Rotate Right” and “Rotate Left”
commands.

+ Added “In Back” and “In Front” options to the “Grid Settings” dialog. The “In Front” option displays the grid in front of a page's
content.

» Adding and deleting pages is now undoable.

+ TextAreas now automatically grow larger (vertically) if you add text that will not fit.

Enhancements

+ Saving files is faster and more reliable.

+ Improved image quality when saving or exporting pages as JPEG.

» Reduced memory usage by approximately 60%. Peak RAM usage is still high, but it is faster on low RAM machines and
better at dealing with high resolution images.

+ Copying objects using Edit > Copy is (in most cases) three times faster.

+ Contextual menus are smarter and, hopefully, more useful.

+ Dropping an image into a shape that already contains an image now provides a warning that the current image will be
replaced. (Some users were disconcerted when the current image unexpectedly disappeared.)

+ Accepting a drop of any kind now causes iRemember to come to the front.

» When an image is dropped into the fill pattern well, we now scale the image so multiple copies appear and it looks more like a
pattern.

- Dropping a template on a page that already contains shapes now gives the user a choice: Create a new page and place the
template on it; replace the existing shapes on the target page; or cancel the template drop.

* When dragging and dropping a template, the grid settings are now copied.

» Dropping an image onto a page has always created a shape, however, now the new shape's aspect ratio (proportions)
matches that of the image and the image is scaled to fit the shape.

+ The Arrange menu has been significantly reworked. The previous “Align to Grid” command has been renamed “Fit to > Grid”.
The Arrange menu's commands are smarter about when they are enabled and more tolerant of locked objects in a selection.

+ Option clicking on an unselected shape that contains an image now allows you to immediately begin moving the embedded
image.

+ iRemember now offers to open an “Untitled” document when it is started (or becomes active) without a file (or other
document).

» The page thumbnails in the drawer now always reflect the content of the page — instead of waiting until you change to
another page.

« Changing pages no longer "loses" undo actions — the number of undo actions is now (theoretically) unlimited.

+ Several actions that were not previously undoable (for example changing grid settings and changing a few controls in the
Inspector), now are.

* The default grid color is now semi-transparent.

* You can now change some attributes of selected TextAreas (via the Format menu) without first double clicking to get into text
edit mode.

» The controls in the horizontal ruler area are now disabled when they are inapplicable.

+ The controls in the Inspector are now more accurate about reflecting those actions that are meaningful for the current
selection. (For example, if the selected shape(s) cannot have their stroke join setting changed, this control is disabled.)

» When iRemember is placed in the background, the Inspector panel now only remains visible when inspecting one or more
graphics that accept an image drop. Clicking on the Inspector window while iRemember is in the background brings
iRemember to the front.

» Whether the Font and Color Picker panels were open when you last quit is now remembered between sessions.

 The face of the rubber stamp tool more accurately reflects the action that will be taken as the result of a mouse click.

+ It is now more difficult to overwrite documents created with newer versions of iRemember or corrupt documents.

+ iRemember now asks the user to locate iRemember ClipArt if the latter has been moved from its expected location.

* We expect to be compatible with Leopard, although we have only tested with beta versions at this time.



Bug Fixes

+ Saving a page as a JPEG was rendering shape shadows differently than they were shown on screen or printing.

» The shadow drawing for shapes has been reworked. A stroke shadow no longer draws on top of an embedded image or fill
pattern, and instead appears behind these elements. Also, a stroke's shadow no longer changes when the fill color is turned
on or off. The previous visual anomaly with Shadows drawn at precisely 0 or 180 degrees under Panther no longer applies.
NOTE: You should carefully review your existing documents that use shadows. They may not appear exactly as they did
before.

+ Opening a template was not restoring the grid settings associated with the template.

» You could not drag-select on top of a locked shape. In other words, locked backgrounds no longer prevent selection by
dragging.

- The menus were not enabled correctly after dropping text onto a page.

+ Holding down the Control key while creating a shape caused a useless contextual menu to pop-up when you finished.

+ Changing the grid color while editing text changed the color of any selected text.

+ Templates you create and save with iRemember can now be added to iRemember ClipArt's database of clip art (via drag &
drop).

Miscellaneous Bug Fixes from 2.0.1 to 2.0.2 (2007-January-11)

Improved error handling for obscure Internet errors.

Miscellaneous Bug Fixes from 2.0 to 2.0.1 (2006-November-17)
Corrected a bug that was causing iRemember ClipArt to hang upon launch for non-admin users.

New Features and Enhancements in Version 2.0 (2006-August-10)

Added over 15,000 pieces of clip art including many photorealistic embellishments:
+ Borders
+  Brads - New!
«  Buttons - New!
+  Corners
. Ribbons - New!
+  Tags - New!

Each of the embellishments is available in a number of styles and over 140 colors. The perfect button or tag for your page is only
a few clicks away.

Patterns
Twenty new grayscale patterns may be combined with the fill color of your choice. The result... Now you can create a virtually
unlimited number of simulated textured papers for use as backgrounds or mattes.

Gradients
Combine pre-rendered gradient objects with your photos using opacity controls to produce a range of new looks & styles
traditional scrapbookers can't match.

iRemember ClipArt
+  FASTER (up to four times)
» Incrementally adds clip art to your search results to reduce waiting
»  Added more clip art categories for fast access to the new embellishments
»  Color selection to help you locate embellishments of a specific color quickly
+  Download even more clip art and templates from our online web store

For details see the iRemember ClipArt Help inside the iRemember ClipArt application.

Known Issues

This section describes technical problems and software conflicts you might encounter in iRemember. For information on other
issues not listed here, visit the support section of the macscrapbook.com web site.

Searching iRemember Clipart

Enter keywords that describe what you are looking for when searching the clip art database. The more keywords you type, the
more specific your search becomes and the fewer items will be displayed. The text supplied in the search field is used to perform
a "begins with" search on all keywords attached to the clip art. For example entering "snow" in the search field matches all clip art
that have a keyword that begins with "snow". This would include: snow, snowman, snowflake etc.

Shadowing Objects Appears To Not Work
The Shadow effect is applied to the combination of the Stroke and Fill Color areas of an object. It is not applied to an embedded
image. You can create situations where a Shadow effect does not appear to do anything. Consider the following steps:



Create a rectangle object (with the default stroke width of 1 pixel)

Embed an image in the rectangle. (Size the image to fill the rectangle.)

Click on the Shadow option in the Shape tab of the Inspector. (Observe the object is shadowed.)

Uncheck the Fill Color option in the Fill tab of the Inspector. (Observe the shadow almost completely disappears.)

PO~

Although it appears the object should have a substantial shadow, it won't because the shadow effect is applied to the
combination of the Stroke and Fill Color areas of the object. In this case, only the stroked outline of the object is shadowed and
since it is only a 1 pixel wide stroke, the shadow is almost completely invisible. In this case, the Fill Color option should remain
checked to give the appearance that the image is shadowed. Alternately, the Stroke width could be increased to make the
Shadow of the object's frame more obvious.

Images Embedded in Text

Word processing applications (MS Word for example) treat all images within their documents as part of the text. When dragging
an image from MS Word it will be imported as part of a new text object. Although iRemember supports importing images in this
manner, you will be limited to the features of a text object. We recommend you locate the original image file and embed it within
an iRemember object/shape for greater control.

Saving Scrapbooks over a Network

If you open a scrapbook that is stored on a remote server, when you go to save your changes, if you did not create the original
scrapbook, you will not be able to save the file. In this case, do a Save As and save the file to your computer and then copy the
saved file back to the server.

Legal Notices

iRemember is a trademark of Intriguing Development, Inc.

iRemember application ©2005-2008 Intriguing Development, Inc. All Rights Reserved.

iRemember Clipart application ©2005-2008 Intriguing Development, Inc. All Rights Reserved.

Portions of digital image content ©1996-2007 DMS Clipart, All Rights Reserved.

Portions of digital image content ©1997-2007 Hemera Technologies Inc., a wholly owned subsidiary of Jupiterimages Corporation.
All Rights Reserved.

Portions of digital image content ©2005-2008 Intriguing Development, Inc. All Rights Reserved.

Portions of digital image content are in the public domain and were selected from the Open Clip Art Library. hitp://openclipart.org



